GPU computacional en WSL y mas facil instalar WSL

wsl 2
wsl 2

Hay tres nuevas y emocionantes actualizaciones para el Subsistema de Windows para Linux (WSL) en el nuevo Windows Insider Preview Build 20150.

Soporte computacional en la GPU para el subsistema Windows para Linux
Miceosoft se está dirigiendo a la característica más solicitada de WSL añadiendo soporte computacional en la GPU. Esta actualización incluirá soporte para NVIDIA CUDA, que ayudará a los profesionales a usar sus máquinas locales de Windows para el desarrollo y experimentación del lazo interno. Además, esto también soportará DirectML, lo que permitirá a los estudiantes y principiantes utilizar la formación acelerada de hardware en la amplitud del hardware de Windows, a través de las GPU de AMD, Intel y NVIDIA. Para conocer todos los detalles de este anuncio, por favor lea esta entrada de blog: Entrenamiento en ML acelerado por GPU dentro del subsistema Windows para Linux en el blog de desarrolladores de Windows.

Instalación de WSL
Estamos trabajando en hacer WSL más fácil de instalar, y hemos añadido una nueva opción de línea de comandos para hacerlo posible: wsl.exe –install.

Actualización de WSL
El núcleo de Linux que es usado por las distribuciones de WSL 2 está siendo entregado ahora a través de Microsoft Update.
También queríamos agregar opciones de línea de comando para aquellos usuarios que deseen tener un control fino sobre sus versiones del kernel de Linux dentro de WSL. wsl.exe –update y sus opciones

wsl.exe –update Manejar las actualizaciones del kernel de WSL 2. Si no se especifica ninguna opción, esto se actualizará a la última versión del kernel.

wsl.exe –update –status Ver el estado de la actualización. Esto le mostrará en que versión del kernel se encuentra y cuando fue actualizado por última vez.

wsl.exe –update –rollback Volver a una versión anterior del núcleo de Linux

18 junio 2020    WSL ya muestra aplicaciones con GUI y ahora es más fácil de instalar

Add a Comment

Su dirección de correo no se hará público. Los campos requeridos están marcados *